summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rouge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rouge')
-rw-r--r--dev-ruby/rouge/Manifest2
-rw-r--r--dev-ruby/rouge/metadata.xml8
-rw-r--r--dev-ruby/rouge/rouge-1.9.0.ebuild28
-rw-r--r--dev-ruby/rouge/rouge-1.9.1.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/rouge/Manifest b/dev-ruby/rouge/Manifest
new file mode 100644
index 000000000000..e606a7603841
--- /dev/null
+++ b/dev-ruby/rouge/Manifest
@@ -0,0 +1,2 @@
+DIST rouge-1.9.0.tar.gz 400489 SHA256 0e984b91fe2b2eccb35d83735235dd918cc1820338915c20a3d8f34505c586fc SHA512 23853debad31b97bec4644d36692c28078120707db024f6bec18eec9aa7b1f14a1b23c4d553b21c50af29ce7c0bac6774eb1693590a5975acfc0483f6711ff28 WHIRLPOOL d9e5b8c47fbb870cc528c6c9758e7e70ab3022c02e67919fa52f1d948ca6e55a6bbdc3ecbe6b20c832732d5b0e91463d506f9e677fd4dfac443db7cd7e90cf50
+DIST rouge-1.9.1.tar.gz 404243 SHA256 cb858abd36a3f8523ee055ce7c815c6757493f82ffa3db307b90e2ec3bfad15e SHA512 8cffcd8cda0ec76eae198d3a3391be421f223b8ec80054b5bcedce6d6c8b16425ce5476be6de2f1fc92d25b0be2eac621d7e17cd40e5d895549e1ece1e2b24a3 WHIRLPOOL f6a36f93cab5ff69359c7597708f3a18707ecb7ec0c33b6bc7eea6b64bdc320fa388a5871180c16dd7d31a8ea83df09b2938b2487d7b921164653a41bce52a94
diff --git a/dev-ruby/rouge/metadata.xml b/dev-ruby/rouge/metadata.xml
new file mode 100644
index 000000000000..f4ce5d5ee7e3
--- /dev/null
+++ b/dev-ruby/rouge/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jneen/rouge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rouge/rouge-1.9.0.ebuild b/dev-ruby/rouge/rouge-1.9.0.ebuild
new file mode 100644
index 000000000000..6fd101cee319
--- /dev/null
+++ b/dev-ruby/rouge/rouge-1.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition"
+HOMEPAGE="http://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+RESTRICT="test"
+# Depends on dev-ruby/wrong, which is not packaged yet.
diff --git a/dev-ruby/rouge/rouge-1.9.1.ebuild b/dev-ruby/rouge/rouge-1.9.1.ebuild
new file mode 100644
index 000000000000..6fd101cee319
--- /dev/null
+++ b/dev-ruby/rouge/rouge-1.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition"
+HOMEPAGE="http://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+RESTRICT="test"
+# Depends on dev-ruby/wrong, which is not packaged yet.