summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-03-24 08:40:46 +0100
committerHans de Graaff <graaff@gentoo.org>2018-03-24 09:35:34 +0100
commit3907f1e553eb4a469ef2f3c7bb114c77af82fef7 (patch)
treef6cfc54e2e0be9d5ed4a83e186d2d71fe3e4b045 /dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
parentdev-ruby/hashery: add ruby24 (diff)
downloadgentoo-3907f1e553eb4a469ef2f3c7bb114c77af82fef7.tar.gz
gentoo-3907f1e553eb4a469ef2f3c7bb114c77af82fef7.tar.bz2
gentoo-3907f1e553eb4a469ef2f3c7bb114c77af82fef7.zip
dev-ruby/rspec-expectations: add ruby25
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
index 9da5e9c1653a..2c12f2af4421 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -52,7 +52,7 @@ all_ruby_prepare() {
each_ruby_prepare() {
case ${RUBY} in
- *ruby24)
+ *ruby24|*ruby25)
sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
;;
esac