summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-05 08:45:08 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-05 08:58:16 +0100
commit452a400ca0e76e1f80a10efdf61475cec78c94ee (patch)
tree76fae701abd49637ca33fb4e0fa584906cfe4232 /dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
parentdev-ruby/diff-lcs: add ruby26 (diff)
downloadgentoo-452a400ca0e76e1f80a10efdf61475cec78c94ee.tar.gz
gentoo-452a400ca0e76e1f80a10efdf61475cec78c94ee.tar.bz2
gentoo-452a400ca0e76e1f80a10efdf61475cec78c94ee.zip
dev-ruby/rspec-support: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rspec-support/rspec-support-3.8.0.ebuild')
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.8.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild b/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
index e84bff1cedb7..49f58a42c922 100644
--- a/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
+++ b/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -36,4 +36,8 @@ all_ruby_prepare() {
# Avoid a spec requiring a specific locale
sed -i -e '/copes with encoded strings/ s/RSpec::Support::OS.windows?/true/' spec/rspec/support/differ_spec.rb || die
+
+ # Avoid a brittle spec depending on ruby implementation details
+ # should be fixed upstream in next version
+ sed -i -e '/returns a hash containing nodes for each line number/askip "ruby26"' spec/rspec/support/source_spec.rb || die
}