summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-elf/ruby-elf-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-elf/ruby-elf-9999.ebuild')
-rw-r--r--dev-ruby/ruby-elf/ruby-elf-9999.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/ruby-elf/ruby-elf-9999.ebuild b/dev-ruby/ruby-elf/ruby-elf-9999.ebuild
new file mode 100644
index 000000000000..2f86a2bb4bea
--- /dev/null
+++ b/dev-ruby/ruby-elf/ruby-elf-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+GITHUB_URI="https://github.com/Flameeyes/${PN}"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${GITHUB_URI}.git"
+fi
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKGEM_GESPEC="${PN}.gemspec"
+
+inherit ruby-fakegem ${EGIT_REPO_URI:+git-2}
+
+if [[ -n ${EGIT_REPO_URI} ]]; then
+ SRC_URI=""
+else
+ SRC_URI="${GITHUB_URI}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Ruby library to access ELF files information"
+HOMEPAGE="http://www.flameeyes.eu/projects/ruby-elf"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="test"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/test-unit:2 )
+ dev-ruby/rake"
+
+# for the man pages
+DEPEND+="
+ dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets"
+
+RDEPEND+="
+ virtual/man"
+
+if [[ ${PV} == "9999" ]]; then
+ all_ruby_unpack() {
+ git_src_unpack
+ }
+fi
+
+all_ruby_compile() {
+ # build the man pages
+ rake manpages || die "rake manpages failed"
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman manpages/*.1
+ dodoc DONATING README.md
+}