summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-21 08:18:20 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-21 08:18:20 +0200
commit935dc79e82751dfb6ac84c51563feb89b42278ae (patch)
treebb69c42b00a0c95c100b0b6eebb34537d3883a63 /dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild
parentdev-ruby/regexp_parser: add 0.4.4 (diff)
downloadgentoo-935dc79e82751dfb6ac84c51563feb89b42278ae.tar.gz
gentoo-935dc79e82751dfb6ac84c51563feb89b42278ae.tar.bz2
gentoo-935dc79e82751dfb6ac84c51563feb89b42278ae.zip
dev-ruby/ruby-filemagic: add 0.7.2, fixing bug 623332
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild')
-rw-r--r--dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild
new file mode 100644
index 000000000000..08d5186dea25
--- /dev/null
+++ b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby binding to libmagic"
+HOMEPAGE="https://github.com/blackwinter/ruby-filemagic"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND} sys-apps/file test? ( >=sys-apps/file-5.30 )"
+RDEPEND="${RDEPEND} sys-apps/file"
+
+all_ruby_prepare() {
+ # Fix up tests for newer sys-apps/file definitions
+ sed -i -e '/test_abbrev_mime_type/,/^ end/ s/ms-office/ms-excel/' test/filemagic_test.rb || die
+
+ # Fix up broken test symlink and regenerate compiled magic file
+ pushd test || die
+ rm -f pylink && ln -s pyfile pylink || die
+ file -C -m perl || die
+ popd || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/filemagic extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/filemagic
+ mv ext/filemagic/ruby_filemagic$(get_modname) lib/filemagic/ || die
+}
+
+each_ruby_test() {
+ find test
+ ${RUBY} -Ctest -I../lib filemagic_test.rb || die
+}