summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-11 21:18:49 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-11 21:18:49 +0100
commite009fa622dd99c9ef7928d80f07aaabb4795dcfe (patch)
tree3c3c1e7248d865ff16f512a8e46fad090c208512 /dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild
parentdev-ruby/ruby-atk: add 3.3.2 (diff)
downloadgentoo-e009fa622dd99c9ef7928d80f07aaabb4795dcfe.tar.gz
gentoo-e009fa622dd99c9ef7928d80f07aaabb4795dcfe.tar.bz2
gentoo-e009fa622dd99c9ef7928d80f07aaabb4795dcfe.zip
dev-ruby/ruby-gdkpixbuf2: add 3.3.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild')
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild
new file mode 100644
index 000000000000..e043f690829f
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_NAME="gdk_pixbuf2"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/${RUBY_FAKEGEM_NAME}
+
+DESCRIPTION="Ruby GdkPixbuf2 bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND+=" x11-libs/gtk+:2"
+
+ruby_add_rdepend "
+ ~dev-ruby/ruby-gio2-${PV}
+"
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}