summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-25 07:57:30 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-25 11:20:12 +0200
commit6f025286755ebc22d67b074119d135e0b6cd7d6d (patch)
tree15eb8cedfaeecdfd7c1dbcdbac778bc695ec54f9 /dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild
parentdev-ruby/ruby-glib2: add 3.0.8 (diff)
downloadgentoo-6f025286755ebc22d67b074119d135e0b6cd7d6d.tar.gz
gentoo-6f025286755ebc22d67b074119d135e0b6cd7d6d.tar.bz2
gentoo-6f025286755ebc22d67b074119d135e0b6cd7d6d.zip
dev-ruby/ruby-gobject-introspection: add 3.0.8
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild
new file mode 100644
index 000000000000..8799d919255d
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}