summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-11-26 11:07:46 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-02 07:30:32 +0100
commit0b9d1a1710bc7e424a773c83aafa6741e990cfde (patch)
tree33fb8ffdb17cf62de296bf2194314507e71c33ed /dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild
parentdev-ruby/ruby-opengl: cleanup; drop hppa stable, bug 626570 (diff)
downloadgentoo-0b9d1a1710bc7e424a773c83aafa6741e990cfde.tar.gz
gentoo-0b9d1a1710bc7e424a773c83aafa6741e990cfde.tar.bz2
gentoo-0b9d1a1710bc7e424a773c83aafa6741e990cfde.zip
dev-ruby/ruby-ldap: cleanup; drop hppa stable, bug 626682
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild
deleted file mode 100644
index 55450913c9ca..000000000000
--- a/dev-ruby/ruby-ldap/ruby-ldap-0.9.17.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
-
-DESCRIPTION="A Ruby interface to some LDAP libraries"
-HOMEPAGE="http://ruby-ldap.sourceforge.net/"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 ~sparc x86 ~x86-macos"
-IUSE="ssl"
-DEPEND=">=net-nds/openldap-2
- dev-libs/cyrus-sasl
- ssl? ( dev-libs/openssl:0 )"
-RDEPEND="${DEPEND}"
-
-# Current test set is interactive due to certificate generation and requires
-# running LDAP daemon
-RESTRICT="test"
-
-each_ruby_configure() {
- local myconf="--with-openldap2"
- if ! use ssl ; then
- myconf="${myconf} --without-libcrypto --without-libssl"
- fi
- ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined::' \
- -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1
- cp ldap$(get_modname) lib/ || die
-}