summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-21 06:36:19 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-21 07:07:48 +0200
commit166ae9ec2256f228ac7d6c93e8ca3870999e3ff0 (patch)
tree8c91efe481a94e1053ab49745bb9f6bad4a5d9e3 /dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild
parentdev-ruby/rake-compiler: cleanup (diff)
downloadgentoo-166ae9ec2256f228ac7d6c93e8ca3870999e3ff0.tar.gz
gentoo-166ae9ec2256f228ac7d6c93e8ca3870999e3ff0.tar.bz2
gentoo-166ae9ec2256f228ac7d6c93e8ca3870999e3ff0.zip
dev-ruby/ruby-ldap: add 0.9.19
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild
new file mode 100644
index 000000000000..aa8cf8f6457b
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1
+ cp ldap$(get_modname) lib/ || die
+}