summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-10 18:57:40 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-10 19:26:38 +0200
commitb9591f3d67a680cc8aace0638a2e466d1d0121d5 (patch)
tree7c1a0b8592d4366d67428ca48e17eca8ede4879e /dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
parentdev-ruby/ruby_parser: cleanup (diff)
downloadgentoo-b9591f3d67a680cc8aace0638a2e466d1d0121d5.tar.gz
gentoo-b9591f3d67a680cc8aace0638a2e466d1d0121d5.tar.bz2
gentoo-b9591f3d67a680cc8aace0638a2e466d1d0121d5.zip
dev-ruby/ruby-oci8: add 2.2.7
Untested blind bump. Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
new file mode 100644
index 000000000000..abfaaa2c4070
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}