summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-ruby/ruby-oci8
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-oci8')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.2.5.1.ebuild4
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.2.5.1.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.2.5.1.ebuild
index a459c32c20db..92543abfde96 100644
--- a/dev-ruby/ruby-oci8/ruby-oci8-2.2.5.1.ebuild
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.2.5.1.ebuild
@@ -29,12 +29,12 @@ each_ruby_configure() {
each_ruby_compile() {
# compile the native libraries
- emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+ emake -C ${EXT_DIR} V=1
}
each_ruby_install() {
# install the native libraries
- emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ emake -C ${EXT_DIR} install DESTDIR="${D}"
# install the gem files
each_fakegem_install
}
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
index 12dff4947bbc..4e29e5166b57 100644
--- a/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.2.7.ebuild
@@ -29,12 +29,12 @@ each_ruby_configure() {
each_ruby_compile() {
# compile the native libraries
- emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+ emake -C ${EXT_DIR} V=1
}
each_ruby_install() {
# install the native libraries
- emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ emake -C ${EXT_DIR} install DESTDIR="${D}"
# install the gem files
each_fakegem_install
}