summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-opengl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-opengl')
-rw-r--r--dev-ruby/ruby-opengl/Manifest2
-rw-r--r--dev-ruby/ruby-opengl/metadata.xml8
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.8.0.ebuild54
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.9.2.ebuild50
4 files changed, 114 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/Manifest b/dev-ruby/ruby-opengl/Manifest
new file mode 100644
index 000000000000..b22fb9529574
--- /dev/null
+++ b/dev-ruby/ruby-opengl/Manifest
@@ -0,0 +1,2 @@
+DIST opengl-0.8.0.gem 458240 SHA256 cf6bed386dcf59749e089c3b9c4bfa9e7dae125b2e83d157e497ef332afcfd23 SHA512 cbae860fe5a486dfa6ff5f4a2d381cc000ae89f3ac386885416c2cab7e03266f017e456ce95ea83c559784e6ab50e18a947003bad9e420fcabed3ab63abd9965 WHIRLPOOL a3ae1f2ca9f22836b7376b1fff3e464eae4984bdd6a167e0a379f09e02f1b09a78962617572511f09261e5edcd3a01210cb43cb3d57b1f8b9186a3dc2e2ff3c0
+DIST opengl-0.9.2.gem 444416 SHA256 cf421841af7c8beb9768aaf755124e17a09f726ea7c91af0f8cd92941036f2cb SHA512 0a7fe8d064e90df5b0507d667d30c3158671861c944086660470f23950606bb821e431735067dfbb2f9b97ebf68041b4937d4330907c4aa3daeb21d5b7e61c37 WHIRLPOOL 7d014cbfa7c0b3eaa206ad9a3c29e78f1cb03f170a10aa5a537fc8504176e794144591131b2ff0db029907b2ba9204b6a47c59ce733d6f2a4c7c8667a08743f4
diff --git a/dev-ruby/ruby-opengl/metadata.xml b/dev-ruby/ruby-opengl/metadata.xml
new file mode 100644
index 000000000000..5939aded1f8a
--- /dev/null
+++ b/dev-ruby/ruby-opengl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">larskanis/opengl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.8.0.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.8.0.ebuild
new file mode 100644
index 000000000000..9787b2332caa
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="http://ruby-opengl.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+
+IUSE=""
+
+DEPEND="${DEPEND}
+ virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${RDEPEND}
+ virtual/opengl
+ media-libs/freeglut"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/opengl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/opengl V=1
+
+ cp ext/*/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r docs
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Failed installing example files."
+}
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.9.2.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.9.2.ebuild
new file mode 100644
index 000000000000..6a8772f17d49
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.9.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/opengl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/opengl V=1
+
+ cp ext/*/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}