summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-openid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-openid')
-rw-r--r--dev-ruby/ruby-openid/Manifest2
-rw-r--r--dev-ruby/ruby-openid/metadata.xml8
-rw-r--r--dev-ruby/ruby-openid/ruby-openid-2.6.0.ebuild31
-rw-r--r--dev-ruby/ruby-openid/ruby-openid-2.7.0.ebuild31
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/ruby-openid/Manifest b/dev-ruby/ruby-openid/Manifest
new file mode 100644
index 000000000000..198c42286cd4
--- /dev/null
+++ b/dev-ruby/ruby-openid/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-openid-2.6.0.tar.gz 514492 SHA256 5c820410d4d83a02cbc778d647e81848a74c7e2f08db0fa560c481ec3d562df3 SHA512 ffe544a8c34c0f2b85073ee679728a6138f0c4da9d16d54001c5aa50251bf51e097baeda5ea748218d06c3bdb69f4f0948c561f888741c88c829bd5d58e7ba44 WHIRLPOOL 11b26774069831a232cbc893c2d6d47fcf71a366b45a92a6e3732a31fa10c879b4cc12217bec16ea42d51938cdeb8b31d9b1d49dd036635fab7135af755df3cd
+DIST ruby-openid-2.7.0.tar.gz 513958 SHA256 3281528cb8fd42d239b841147b5a560292bda1899bd79fa83b407b1c1b24e40e SHA512 e53104d4cf0198953172a2ed567877c3d1cc11664acbab8ca424823e2249d9fa13ad9b931a7318709f2865f3f16e0e38714428d12accf16080aa1818b673d8cd WHIRLPOOL f293b3f76c9ebeaa0229327c6900a4eeae36cfc9abb97af5ac1c00ad99eb0b13f8765178789b7c9c16c7d783e0c3cfc43885112178b90be2ae22989497977f7c
diff --git a/dev-ruby/ruby-openid/metadata.xml b/dev-ruby/ruby-openid/metadata.xml
new file mode 100644
index 000000000000..316cfe27830c
--- /dev/null
+++ b/dev-ruby/ruby-openid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">openid/ruby-openid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-openid/ruby-openid-2.6.0.ebuild b/dev-ruby/ruby-openid/ruby-openid-2.6.0.ebuild
new file mode 100644
index 000000000000..bd89b3cf18f2
--- /dev/null
+++ b/dev-ruby/ruby-openid/ruby-openid-2.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md NOTICE UPGRADE.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A robust library for verifying and serving OpenID identities"
+HOMEPAGE="http://ruby-openid.rubyforge.org/"
+SRC_URI="https://github.com/openid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-macos"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
diff --git a/dev-ruby/ruby-openid/ruby-openid-2.7.0.ebuild b/dev-ruby/ruby-openid/ruby-openid-2.7.0.ebuild
new file mode 100644
index 000000000000..34fc0584fe98
--- /dev/null
+++ b/dev-ruby/ruby-openid/ruby-openid-2.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md NOTICE UPGRADE.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A robust library for verifying and serving OpenID identities"
+HOMEPAGE="http://ruby-openid.rubyforge.org/"
+SRC_URI="https://github.com/openid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-macos"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}