summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-07 08:08:27 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-07 08:08:27 +0200
commitff3b87cbfd30821ce1fe6198c90ce17a1073c745 (patch)
tree655b5cdd1b0bae2e83aebc018b5e3123dce53333 /dev-ruby/rubypants/rubypants-0.5.0.ebuild
parentxfce-base/exo: Bump to 0.11.0, with new experimental GTK+3 variant (diff)
downloadgentoo-ff3b87cbfd30821ce1fe6198c90ce17a1073c745.tar.gz
gentoo-ff3b87cbfd30821ce1fe6198c90ce17a1073c745.tar.bz2
gentoo-ff3b87cbfd30821ce1fe6198c90ce17a1073c745.zip
dev-ruby/rubypants: add 0.5.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/rubypants/rubypants-0.5.0.ebuild')
-rw-r--r--dev-ruby/rubypants/rubypants-0.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rubypants/rubypants-0.5.0.ebuild b/dev-ruby/rubypants/rubypants-0.5.0.ebuild
new file mode 100644
index 000000000000..a95975b6612a
--- /dev/null
+++ b/dev-ruby/rubypants/rubypants-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby port of the SmartyPants PHP library"
+HOMEPAGE="http://chneukirchen.org/repos/rubypants/README"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I. test/rubypants_test.rb || die "tests failed"
+}