summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-07 06:20:39 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-07 06:20:39 +0100
commitd8254f4edc949f053f49caf19b603445715264f1 (patch)
tree89c25c05483767fa4cbc79b1bec036c301204578 /dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild
parentdev-ruby/curses: add 1.1.2 (diff)
downloadgentoo-d8254f4edc949f053f49caf19b603445715264f1.tar.gz
gentoo-d8254f4edc949f053f49caf19b603445715264f1.tar.bz2
gentoo-d8254f4edc949f053f49caf19b603445715264f1.zip
dev-ruby/selenium-webdriver: add 3.0.7
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild')
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild
new file mode 100644
index 000000000000..85b522ce54df
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-3.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ dev-ruby/rubyzip:1"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}