summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-30 06:37:03 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-30 07:16:23 +0200
commit82579af640b353f6063e292b7efed050a54620ca (patch)
tree15e33b1ed6a38cfb3c13342ff7dcb815876f9018 /dev-ruby/selenium-webdriver
parentdev-lang/abs: Bump to version 2.5.1 (diff)
downloadgentoo-82579af640b353f6063e292b7efed050a54620ca.tar.gz
gentoo-82579af640b353f6063e292b7efed050a54620ca.tar.bz2
gentoo-82579af640b353f6063e292b7efed050a54620ca.zip
dev-ruby/selenium-webdriver: add 4.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-4.0.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index f2ee31ba0e71..650e0b6eb536 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -1,3 +1,4 @@
DIST selenium-webdriver-3.142.7.gem 865280 BLAKE2B 650011848afaa3ea4fab7c8172828c7562df212383a8fbea9615a5136e3382aba0fcf17952d941c7b514e5229c0aafe3dbc320386698eb8756f567eff67722bd SHA512 0e7891c19b8a0b20441d85bc17032ecf03cba7ca435846e03abc50b62b0c53c075dc70456796c9bfcd1ecd28ecc517f907a3d6868346a07617fd1d0c1b9437c0
DIST selenium-webdriver-4.0.0.gem 152576 BLAKE2B 8a1394fb1c9cc3603081454c4946f0ad5207d113bb37c488207baaaaaff69f2848b2b5bc9b9221177d01c86b635dd222933be3561eacfa164539c99c8cf149a6 SHA512 db8fd0a05fc38e7f55c2b9a779462416b937d3b8e732dee6b7bcf2b3f8914417a79e8649e320e348359ab133cef20a75e2033385e8b125e5dfc52645b086045b
DIST selenium-webdriver-4.0.2.gem 152576 BLAKE2B ed4f33235f5ddbba6093d6c4c98ed2c5f95766b772fb302339101466a7d1b6af5dd322579c20b3b5c61c3fbb4b2d1d572612909e1b342a588fe8abbeaab2dcfb SHA512 e0efd6a051bef551943e3b43810930362013c3fc973415929a28152311a8b92dd241e49e0d3b3a839ed2b3197481f6d70b118bf2e4345f02853d8a6bb1214cea
+DIST selenium-webdriver-4.0.3.gem 152576 BLAKE2B 671909863bbbe328bbaf30a9e3c9e459e9eb6b892f554729892327230c03dd03f7819d9e8beb901cea986cb0d97877ce49853de856e1f802369686a03e5e9086 SHA512 260ad111ef9c512835f410fc7283df90b245d42db12274028148575e0a89a8c71639f0132a621f326921317b3181564521d9e801f2a7f14e5f196cde2550773c
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.3.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.3.ebuild
new file mode 100644
index 000000000000..48a9afa6621d
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_GEMSPEC="selenium-webdriver.gemspec"
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubyzip-1.2.2:*"