summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-21 07:11:15 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-21 08:38:19 +0100
commit096e44d7ab4025811301fcbb7d362e95e6ae259c (patch)
tree6050525def909043f884513466e127692ac4d60e /dev-ruby/shoulda
parentdev-ruby/shoulda-matchers: add ruby30; EAPI 8 (diff)
downloadgentoo-096e44d7ab4025811301fcbb7d362e95e6ae259c.tar.gz
gentoo-096e44d7ab4025811301fcbb7d362e95e6ae259c.tar.bz2
gentoo-096e44d7ab4025811301fcbb7d362e95e6ae259c.zip
dev-ruby/shoulda: add ruby30; EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/shoulda-3.6.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-3.6.0-r2.ebuild b/dev-ruby/shoulda/shoulda-3.6.0-r2.ebuild
new file mode 100644
index 000000000000..6eb50ff9f0c3
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-3.6.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1
+ dev-ruby/shoulda-matchers:3"
+
+all_ruby_prepare() {
+ sed -e '/executables/,/^ end/d ; /test_files/d; s/git ls-files/find * -print/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}