summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-12 09:32:07 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-12 09:32:37 +0100
commit8bcd1735aef6896e7cb4a8840d0bd53b5f357a33 (patch)
treec6e3ea591eff5b1121b285de98204fb4d0624506 /dev-ruby/shoulda
parentdev-ruby/shoulda-matchers: enable ruby33 (diff)
downloadgentoo-8bcd1735aef6896e7cb4a8840d0bd53b5f357a33.tar.gz
gentoo-8bcd1735aef6896e7cb4a8840d0bd53b5f357a33.tar.bz2
gentoo-8bcd1735aef6896e7cb4a8840d0bd53b5f357a33.zip
dev-ruby/shoulda: add 4.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/Manifest1
-rw-r--r--dev-ruby/shoulda/shoulda-4.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/Manifest b/dev-ruby/shoulda/Manifest
index 806a7dfc7d10..28daf91eead2 100644
--- a/dev-ruby/shoulda/Manifest
+++ b/dev-ruby/shoulda/Manifest
@@ -1 +1,2 @@
DIST shoulda-3.6.0.tar.gz 22691 BLAKE2B 798b88e208355b0325b9e8b48f66687ad2702e1b5fc058d45504648fe7c7760b018eaf3d1c7bd45c68656c7bbba8fccc9b74d72003ee0b78ac53a277567609bb SHA512 10f7c6801eaabafa08eb2bc9c4d2a96237d4494aee7d40e5db8cf9c1abd8cccfe86aa21b0e68e2ec42cf222d285cdbec11ed2fdd804ffb8bd65ffd2efa3e72ac
+DIST shoulda-4.0.0.tar.gz 17408 BLAKE2B 8e5bd8b5a01292d8c08f76434496a3e99669f4c02c35092e17f4216a8164867f476c6a596a9f1986416106f21daa0d0b24ddb2d04be13c8b2583e98715301bf8 SHA512 850cc685d055ae1e7367f48e963d2839fee3c48a076e079bf3e1c6de2e30d808e78c07c425d0bbcf7ceaeeb944dc647c4f11ceac1ca48134b6b8b555fda53bfe
diff --git a/dev-ruby/shoulda/shoulda-4.0.0.ebuild b/dev-ruby/shoulda/shoulda-4.0.0.ebuild
new file mode 100644
index 000000000000..87c0b420b2b1
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend "
+ dev-ruby/shoulda-context:2
+ dev-ruby/shoulda-matchers:4"
+
+all_ruby_prepare() {
+ sed -e '/executables/,/^ end/d ; /test_files/d; s/git ls-files/find * -print/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}