summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-04 06:47:34 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-04 06:47:34 +0200
commitf6b34430374f52f0ed3425195219a4a28daf0bb3 (patch)
tree291b7bc1e8cd531a005c7a5459a0d4331272e60a /dev-ruby/simplecov/simplecov-0.12.0.ebuild
parentdev-ruby/seed-fu: add 2.3.6 (diff)
downloadgentoo-f6b34430374f52f0ed3425195219a4a28daf0bb3.tar.gz
gentoo-f6b34430374f52f0ed3425195219a4a28daf0bb3.tar.bz2
gentoo-f6b34430374f52f0ed3425195219a4a28daf0bb3.zip
dev-ruby/simplecov: add 0.12.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.12.0.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.12.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.12.0.ebuild b/dev-ruby/simplecov/simplecov-0.12.0.ebuild
new file mode 100644
index 000000000000..33cfef060368
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and merging across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/json-1.8 <dev-ruby/json-3
+ dev-ruby/simplecov-html:0.10
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+ dev-util/cucumber
+ dev-util/aruba
+ dev-ruby/capybara
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+# ${RUBY} -S cucumber features || die
+}