summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/sinatra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/sinatra')
-rw-r--r--dev-ruby/sinatra/Manifest1
-rw-r--r--dev-ruby/sinatra/files/sinatra-1.4.4-fix-tests.patch25
-rw-r--r--dev-ruby/sinatra/metadata.xml5
-rw-r--r--dev-ruby/sinatra/sinatra-1.4.6-r1.ebuild34
-rw-r--r--dev-ruby/sinatra/sinatra-1.4.6.ebuild31
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-ruby/sinatra/Manifest b/dev-ruby/sinatra/Manifest
new file mode 100644
index 000000000000..d62617b56b31
--- /dev/null
+++ b/dev-ruby/sinatra/Manifest
@@ -0,0 +1 @@
+DIST sinatra-1.4.6.gem 355840 SHA256 87225b2bc25d5806b24bfac05383d4224109ce073b7ece1d3d55e58018e615c2 SHA512 3b80137a8c31bc60c24b4fb4e5984fc9064f52733f5a7214079a50d1c9acfa3046f06935c7eeb611aa4e3d0979fcd88c8db741a08429000a2fb94956c7648552 WHIRLPOOL 7ae683bc03f355c4e99ea94a6661cf89e2effc857e74c7ec0e4d86572999139460b3cb8f3bfa2db8a36c18e6ac9f2d20347d0163cd0271121ac5bdbff8a33ef6
diff --git a/dev-ruby/sinatra/files/sinatra-1.4.4-fix-tests.patch b/dev-ruby/sinatra/files/sinatra-1.4.4-fix-tests.patch
new file mode 100644
index 000000000000..25ed73097bf6
--- /dev/null
+++ b/dev-ruby/sinatra/files/sinatra-1.4.4-fix-tests.patch
@@ -0,0 +1,25 @@
+commit c5c9f6b5501a366d5809faa44e50fad371c14870
+Author: Jon Rowe <hello@jonrowe.co.uk>
+Date: Tue Oct 29 14:18:46 2013 +1100
+
+ fixes the build by disabling path traversal protection for this test
+
+ Seems that this test is in direct competition with the desired
+ behaviour of path traversal protection.
+
+diff --git a/test/routing_test.rb b/test/routing_test.rb
+index 410bfda..5584601 100644
+--- a/test/routing_test.rb
++++ b/test/routing_test.rb
+@@ -90,7 +90,10 @@ class RoutingTest < Test::Unit::TestCase
+ end
+
+ it "it handles encoded slashes correctly" do
+- mock_app { get("/:a") { |a| a } }
++ mock_app {
++ set :protection, :except => :path_traversal
++ get("/:a") { |a| a }
++ }
+ get '/foo%2Fbar'
+ assert_equal 200, status
+ assert_body "foo/bar"
diff --git a/dev-ruby/sinatra/metadata.xml b/dev-ruby/sinatra/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/sinatra/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/sinatra/sinatra-1.4.6-r1.ebuild b/dev-ruby/sinatra/sinatra-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..c7592f4e624b
--- /dev/null
+++ b/dev-ruby/sinatra/sinatra-1.4.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# no documentation is generable, it needs hanna, which is broken
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS.md CHANGES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort"
+HOMEPAGE="http://www.sinatrarb.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/rack-1*:* >=dev-ruby/rack-1.4:*
+ >=dev-ruby/rack-protection-1.4:1
+ >=dev-ruby/tilt-1.3.4:* <dev-ruby/tilt-3:*"
+ruby_add_bdepend "test? ( >=dev-ruby/rack-test-0.5.6 dev-ruby/erubis dev-ruby/builder )"
+
+# haml tests are optional and not yet marked for ruby20.
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( >=dev-ruby/haml-3.0 )"
+
+all_ruby_prepare() {
+ # Remove implicit build dependency on git.
+ sed -i -e '/\(s.files\|s.test_files\|s.extra_rdoc_files\)/d' sinatra.gemspec || die
+}
diff --git a/dev-ruby/sinatra/sinatra-1.4.6.ebuild b/dev-ruby/sinatra/sinatra-1.4.6.ebuild
new file mode 100644
index 000000000000..947c45080d0a
--- /dev/null
+++ b/dev-ruby/sinatra/sinatra-1.4.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+# no documentation is generable, it needs hanna, which is broken
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS.md CHANGES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort"
+HOMEPAGE="http://www.sinatrarb.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/rack-1*:* >=dev-ruby/rack-1.4:*
+ >=dev-ruby/rack-protection-1.4:1
+ >=dev-ruby/tilt-1.3.4:* <dev-ruby/tilt-3:*"
+ruby_add_bdepend "test? ( >=dev-ruby/rack-test-0.5.6 dev-ruby/erubis dev-ruby/builder )"
+
+all_ruby_prepare() {
+ # Remove implicit build dependency on git.
+ sed -i -e '/\(s.files\|s.test_files\|s.extra_rdoc_files\)/d' sinatra.gemspec || die
+}