summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-22 07:20:23 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-22 07:20:23 +0100
commita6bc1cf26aae4da6e0aa92f575bc3e71ab68d604 (patch)
tree87f5ab2811dd2148486f95a7183fcbac3b6ebdf1 /dev-ruby/slop/slop-4.3.0.ebuild
parentdev-ruby/slop: drop ruby19, add ruby23 (diff)
downloadgentoo-a6bc1cf26aae4da6e0aa92f575bc3e71ab68d604.tar.gz
gentoo-a6bc1cf26aae4da6e0aa92f575bc3e71ab68d604.tar.bz2
gentoo-a6bc1cf26aae4da6e0aa92f575bc3e71ab68d604.zip
dev-ruby/slop: add 4.3.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/slop/slop-4.3.0.ebuild')
-rw-r--r--dev-ruby/slop/slop-4.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/slop/slop-4.3.0.ebuild b/dev-ruby/slop/slop-4.3.0.ebuild
new file mode 100644
index 000000000000..5a8f80311058
--- /dev/null
+++ b/dev-ruby/slop/slop-4.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}