summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-23 08:01:29 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-23 08:10:32 +0200
commita02ed41e9aa177452cd588406e1cb086f7f1f91a (patch)
tree62932c2aec63966c457d307263bffb86aa52b81d /dev-ruby/sshkit/sshkit-1.11.4.ebuild
parentdev-ruby/stomp: cleanup (diff)
downloadgentoo-a02ed41e9aa177452cd588406e1cb086f7f1f91a.tar.gz
gentoo-a02ed41e9aa177452cd588406e1cb086f7f1f91a.tar.bz2
gentoo-a02ed41e9aa177452cd588406e1cb086f7f1f91a.zip
dev-ruby/sshkit: cleanup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/sshkit/sshkit-1.11.4.ebuild')
-rw-r--r--dev-ruby/sshkit/sshkit-1.11.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ruby/sshkit/sshkit-1.11.4.ebuild b/dev-ruby/sshkit/sshkit-1.11.4.ebuild
deleted file mode 100644
index 732154678b8f..000000000000
--- a/dev-ruby/sshkit/sshkit-1.11.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"' test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}