summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-09-06 07:07:05 +0200
committerHans de Graaff <graaff@gentoo.org>2022-09-06 07:07:05 +0200
commit95508cea4713043423adea612e5e5f100a7e8a4a (patch)
treebd648bb7f6b2b27b519bb6206282f0ba4a6742b9 /dev-ruby/sshkit
parentdev-libs/libofx: fix version in header file; fix parallel build (diff)
downloadgentoo-95508cea4713043423adea612e5e5f100a7e8a4a.tar.gz
gentoo-95508cea4713043423adea612e5e5f100a7e8a4a.tar.bz2
gentoo-95508cea4713043423adea612e5e5f100a7e8a4a.zip
dev-ruby/sshkit: add 1.21.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest1
-rw-r--r--dev-ruby/sshkit/sshkit-1.21.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 2e409842216f..937812815a32 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1 +1,2 @@
DIST sshkit-1.21.2.gem 144896 BLAKE2B ea72b1d0df7252f9c4ffe010721a957b5a86cc43697acf4dfd065a74cca5317deeb15692449d573a2e5590ef3a23ee666196b7b661d6986a2f270d16e2dc8d89 SHA512 37515726b67ae0e2ac9dff42cf7b71a32832ebe144aa192332780e4d9aead1a9e4c3cf7f6f0b994804175a5befd896b32908a82ba2e4f4a1d4e4b0f5bf01c3b3
+DIST sshkit-1.21.3.gem 144896 BLAKE2B 14cf7338187238f720cf8bf39664ba827700c1c47469cbd9e2f154a2b7bc91b4d8d14ec15d76db88fba1d23a936b112f0f2a33f2e15978a85816cd04274aea89 SHA512 ede63fd798db6e49fb2a1e9379699bd3e5de27f6b83640506a848f179fd83efed410357c899e97a41b1ab7e3baf47d88f87dcecf2bbcdf7475bea0d35817a9cc
diff --git a/dev-ruby/sshkit/sshkit-1.21.3.ebuild b/dev-ruby/sshkit/sshkit-1.21.3.ebuild
new file mode 100644
index 000000000000..0c59a5fd2f75
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.21.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha <dev-ruby/net-ssh-7 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ -e '1irequire "set"; require "pathname"' \
+ -e '1igem "net-ssh", "<7"' \
+ -i test/helper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}