summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-11 19:14:38 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-11 19:15:21 +0200
commitd65f543a8534291c12ead9cd9cafa1fc60ffd5f6 (patch)
tree962431b4225f7dec0f98d129dfd36110b91790d1 /dev-ruby/strptime
parentdev-util/hfstospell: gcc-10 fix (diff)
downloadgentoo-d65f543a8534291c12ead9cd9cafa1fc60ffd5f6.tar.gz
gentoo-d65f543a8534291c12ead9cd9cafa1fc60ffd5f6.tar.bz2
gentoo-d65f543a8534291c12ead9cd9cafa1fc60ffd5f6.zip
dev-ruby/strptime: add 0.2.4
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/Manifest1
-rw-r--r--dev-ruby/strptime/strptime-0.2.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/strptime/Manifest b/dev-ruby/strptime/Manifest
index 687f80b2c88f..98817d4643ba 100644
--- a/dev-ruby/strptime/Manifest
+++ b/dev-ruby/strptime/Manifest
@@ -1 +1,2 @@
DIST strptime-0.2.3.tar.gz 17375 BLAKE2B 583566c19cdd96f97b469d3353236624b814ea9200e1479d32c552d06431e0008cd9dcf5be03564948898fb9e5a1470a5a8bdb531d4054bfe64899bbd6ec92e0 SHA512 1b9ee2f7c0fa747c6df5a56c5d7f667c4a9314c334472867e890758074f9da387aae54d9171b2460036a21e890fd743187571c6d4a995e4117d6c4307b8134cc
+DIST strptime-0.2.4.tar.gz 17429 BLAKE2B 9b6a7f29075ef5e55a17f28859961013d96778c7bd78fac9138a455819ec062f4b0d311038026a9da45ecc96e3f92207462970201c5d3095b9b0d653706c64a2 SHA512 ae92df60e049eb57e60f414e0a436fd90b56c6a3f5812597619aaac2d78b80046aeef77cdaae6f8822f37d069903d2806b9f7710ff1520eaf11070aaf3465f56
diff --git a/dev-ruby/strptime/strptime-0.2.4.ebuild b/dev-ruby/strptime/strptime-0.2.4.ebuild
new file mode 100644
index 000000000000..20a5d9d41adc
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/strptime extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/strptime V=1
+ cp ext/strptime/strptime$(get_modname) lib/strptime/ || die
+}