summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-16 07:25:42 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-16 07:26:31 +0200
commit51160a0bf7abdeecf27e98213fc2b07c99776c9b (patch)
treeec0d13efda1e1c1633310e0fcc21c71aacee9de4 /dev-ruby/syslogger/syslogger-1.6.4.ebuild
parentdev-ruby/locale: version bump (diff)
downloadgentoo-51160a0bf7abdeecf27e98213fc2b07c99776c9b.tar.gz
gentoo-51160a0bf7abdeecf27e98213fc2b07c99776c9b.tar.bz2
gentoo-51160a0bf7abdeecf27e98213fc2b07c99776c9b.zip
dev-ruby/syslogger: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/syslogger/syslogger-1.6.4.ebuild')
-rw-r--r--dev-ruby/syslogger/syslogger-1.6.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/syslogger/syslogger-1.6.4.ebuild b/dev-ruby/syslogger/syslogger-1.6.4.ebuild
new file mode 100644
index 000000000000..c5084cf5776e
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.6.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}