summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/syslogger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/syslogger')
-rw-r--r--dev-ruby/syslogger/Manifest2
-rw-r--r--dev-ruby/syslogger/metadata.xml8
-rw-r--r--dev-ruby/syslogger/syslogger-1.6.2.ebuild32
-rw-r--r--dev-ruby/syslogger/syslogger-1.6.3.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/syslogger/Manifest b/dev-ruby/syslogger/Manifest
new file mode 100644
index 000000000000..4c1b876821de
--- /dev/null
+++ b/dev-ruby/syslogger/Manifest
@@ -0,0 +1,2 @@
+DIST syslogger-1.6.2.gem 9728 SHA256 21e72804ff9ba28d36141df304ec32af00aa4e9f712416ed1a384f210d83f3e9 SHA512 84eaeae4804f9507a2e14c9bf9fd090b1b90189558e509848cca10ca7ce2df92c08232df6d2c05bb608a2d2a7fff206a3605064a67940f2cb058371e36138552 WHIRLPOOL e06d5181ff85457aeeb4df1f89b1b030d3549ffb42e6a99eaaac2f84f0f2bd19645a11b24561a711d14e04ed5a2e8638574803be1aaf96d189cda32faae47f6c
+DIST syslogger-1.6.3.gem 10240 SHA256 1ac179d3f310018a861d5e605c4d6910265a59dd1e234cb40fd0f49ce32decf8 SHA512 8256560025e4edba5f6efb865ce0d534926bce02a6ff47e1865f1da182b0ea2528c946beac382c0dd5fa229ed14c485e548befbd1fad45592b965c62d4001263 WHIRLPOOL b5c17c7a7e822bb03f4c085f34a9b4710f30aaea3ad297ab48f928b4a6995bd7419a7f2dbd8a6749637ed1979264c4d9941b5cabc63a4d3cd6f196c99a80212c
diff --git a/dev-ruby/syslogger/metadata.xml b/dev-ruby/syslogger/metadata.xml
new file mode 100644
index 000000000000..4f71e545dd98
--- /dev/null
+++ b/dev-ruby/syslogger/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">crohr/syslogger</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/syslogger/syslogger-1.6.2.ebuild b/dev-ruby/syslogger/syslogger-1.6.2.ebuild
new file mode 100644
index 000000000000..c5084cf5776e
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}
diff --git a/dev-ruby/syslogger/syslogger-1.6.3.ebuild b/dev-ruby/syslogger/syslogger-1.6.3.ebuild
new file mode 100644
index 000000000000..c5084cf5776e
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.6.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}