summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-24 08:12:20 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-24 08:12:43 +0100
commit91e1658ee1b5c4085131091d74bf2c57a556141b (patch)
treef0486ab81f1b6df38b7823746a361d7193af3be6 /dev-ruby/thread_safe/thread_safe-0.3.6.ebuild
parentdev-ruby/flexmock: add 2.3.5 (diff)
downloadgentoo-91e1658ee1b5c4085131091d74bf2c57a556141b.tar.gz
gentoo-91e1658ee1b5c4085131091d74bf2c57a556141b.tar.bz2
gentoo-91e1658ee1b5c4085131091d74bf2c57a556141b.zip
dev-ruby/thread_safe: add 0.3.6
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/thread_safe/thread_safe-0.3.6.ebuild')
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.6.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.6.ebuild
new file mode 100644
index 000000000000..8dc349a555f7
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Higher atomic dependency since earlier versions crash on ruby20 while
+# running thread_safe tests.
+ruby_add_bdepend "test? ( >=dev-ruby/atomic-1.1.16 )"
+
+each_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}