summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/thread_safe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/thread_safe')
-rw-r--r--dev-ruby/thread_safe/Manifest2
-rw-r--r--dev-ruby/thread_safe/metadata.xml8
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.4.ebuild34
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.5.ebuild35
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/thread_safe/Manifest b/dev-ruby/thread_safe/Manifest
new file mode 100644
index 000000000000..c44c7c39e9fb
--- /dev/null
+++ b/dev-ruby/thread_safe/Manifest
@@ -0,0 +1,2 @@
+DIST thread_safe-0.3.4.gem 117760 SHA256 16315baa971c48d00104bcd35e8934e3f9ccfd3b8f429e3fca7ee2dfd81734b2 SHA512 e7297343a63b6d50c6062d65df2a5f29bd03c4ae60181b028d2982f6852699da7bbcc4f49ed14fa06961545f808d635c14596d1009090b171c9d60f86b8d2c09 WHIRLPOOL ef0041d66ce94deecfaec1d060ed5d6bef1d7f94be2b571640c614709868e65b084c228a1b4d15f3ec3ebf4d6bf6d8041baec50d8621025d48aac3f7e192341a
+DIST thread_safe-0.3.5.gem 120832 SHA256 993da065f98b8575c537ebf984ffb79eecdb6064559a3b9d2a9d7aaf313704c3 SHA512 35749e7e9f6a95115d86bbd7bd5cae92f64dbddc36caf5d5ab8bc23db75ade51c31b6b9ef5afac4cfc744cfa624a002468fc0727eff33b69aa80f7bb383df471 WHIRLPOOL 5ab2fc0493b661507fa7d417f8cdaa11b4731c65fb62642be04151210800ef0c96e39c29b9283add3fb5662bc9e36309c8480bc28aead2fd6e5370acfb360069
diff --git a/dev-ruby/thread_safe/metadata.xml b/dev-ruby/thread_safe/metadata.xml
new file mode 100644
index 000000000000..b37175b345f9
--- /dev/null
+++ b/dev-ruby/thread_safe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-concurrency/thread_safe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.4.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.4.ebuild
new file mode 100644
index 000000000000..4dccb6fcdd25
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/headius/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# Higher atomic dependency since earlier versions crash on ruby20 while
+# running thread_safe tests.
+ruby_add_bdepend "test? ( >=dev-ruby/atomic-1.1.16 >=dev-ruby/minitest-4 )"
+
+each_ruby_prepare(){
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.5.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.5.ebuild
new file mode 100644
index 000000000000..a14a5d3885d6
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# Higher atomic dependency since earlier versions crash on ruby20 while
+# running thread_safe tests.
+ruby_add_bdepend "test? ( >=dev-ruby/atomic-1.1.16 >=dev-ruby/minitest-4 )"
+
+each_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/simplecov/,+19d" -e "/minitest\/reporters/,+2d" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}