summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-15 08:56:26 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-15 10:09:19 +0200
commit9bd9b84810933f7171cc1cbf99478da797e07828 (patch)
treeab9d08af919ed4e3a2e665ceaa630c3283588f29 /dev-ruby/tidy-ext
parentdev-ruby/loquacious: EAPI 7 -> 8, add ruby30, ruby31 (diff)
downloadgentoo-9bd9b84810933f7171cc1cbf99478da797e07828.tar.gz
gentoo-9bd9b84810933f7171cc1cbf99478da797e07828.tar.bz2
gentoo-9bd9b84810933f7171cc1cbf99478da797e07828.zip
dev-ruby/tidy-ext: enable ruby30, ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tidy-ext')
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
index aa4500bb1c4b..1027b579d387 100644
--- a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTENSIONS=(ext/tidy/extconf.rb)
@@ -28,4 +28,7 @@ all_ruby_prepare() {
# Avoid spec that needs network connectivity.
rm spec/tidy/remote_uri_spec.rb || die
+
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be_truthy/' spec/tidy/compat_spec.rb || die
}