summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-06 06:37:20 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-06 06:37:20 +0200
commit5148b587b4b435de1a32f5c602c7f26f77a023c8 (patch)
tree8250d3efc46ad46609a7b6beb5a9c0cb91cf6030 /dev-ruby/timecop/timecop-0.9.1.ebuild
parentdev-ruby/syntax: add 1.2.2 (diff)
downloadgentoo-5148b587b4b435de1a32f5c602c7f26f77a023c8.tar.gz
gentoo-5148b587b4b435de1a32f5c602c7f26f77a023c8.tar.bz2
gentoo-5148b587b4b435de1a32f5c602c7f26f77a023c8.zip
dev-ruby/timecop: add 0.9.1
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/timecop/timecop-0.9.1.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/timecop/timecop-0.9.1.ebuild b/dev-ruby/timecop/timecop-0.9.1.ebuild
new file mode 100644
index 000000000000..bb415e704b5f
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="https://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Missing testdep activesupport
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' \
+ -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
+ # FIXME after activesupport gained ruby22 support
+ rm test/time_stack_item_test.rb || die
+}
+
+each_ruby_test() {
+ for f in test/*_test.rb ; do
+ ${RUBY} -Ilib $f || die
+ done
+}