summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/timecop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/timecop')
-rw-r--r--dev-ruby/timecop/Manifest3
-rw-r--r--dev-ruby/timecop/metadata.xml8
-rw-r--r--dev-ruby/timecop/timecop-0.7.1.ebuild33
-rw-r--r--dev-ruby/timecop/timecop-0.7.4.ebuild33
-rw-r--r--dev-ruby/timecop/timecop-0.8.0.ebuild37
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-ruby/timecop/Manifest b/dev-ruby/timecop/Manifest
new file mode 100644
index 000000000000..34741df301b3
--- /dev/null
+++ b/dev-ruby/timecop/Manifest
@@ -0,0 +1,3 @@
+DIST timecop-0.7.1.gem 15360 SHA256 22e529f06739b1361b4e3b40adc667dfa8f50e66b13b778448cf51fb62bc8f2a SHA512 cbc1e1d6575473ed4200e71a8bbc91f4dd78a0e612e08ca236f485a92e71f02621bd199dc32a983dd7eea9a143b8fbf4b833f73016b5a7ea6a7459730efc1d83 WHIRLPOOL f54018f65fdd55c8d7399083a7c9d1f6f1405a6cea5941b8e20ef143d3c4a57350cc2714a2626f918ff753a11dafb506539d41ef4c43464258a2832590215a2a
+DIST timecop-0.7.4.gem 16384 SHA256 bf55bc653c00b8d2531b7863f5686d85fdd12f29dae0775e5aa08541d5de8e7c SHA512 24db648cf8db06e262cb2e063b5a1add778e6894039d59da43d27b77029546e44396671d59b3dcfa958c4a95162160f67011f816238d18b28fa981949107e6f8 WHIRLPOOL 7b5a5d5d0dbbfb6c753090e194bc580ea639ab87f911d453cb96a8d731db6847949da2bc54da873462f8c0030c2a0281f1b786fb9bbb6b71b1f49c6ec93a9e6d
+DIST timecop-0.8.0.gem 16384 SHA256 1ac7a7d13c700d21d13c533ccab3d004ecc2d8ddf339a93df7c29bd12634c47d SHA512 bd47dd44215be3a0ec9bc095094a258a29e79dcbe19d8afde015eef60ff0951888e81a6e0cbf9790789d4d0083265bf91088556d38db58461eb38edae9b15682 WHIRLPOOL ae0b5d7df5bf2cb9b5bd7695ec56b3373e5c3c0b692c86b1ef41affc4bc07441b76c43a977d2bd8f407d1ec0d379e89f96242609b7c53b12df2038bbbd2bd32d
diff --git a/dev-ruby/timecop/metadata.xml b/dev-ruby/timecop/metadata.xml
new file mode 100644
index 000000000000..b024441bd572
--- /dev/null
+++ b/dev-ruby/timecop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jtrupiano/timecop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/timecop/timecop-0.7.1.ebuild b/dev-ruby/timecop/timecop-0.7.1.ebuild
new file mode 100644
index 000000000000..be2ad23fe9e2
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="http://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
+}
+each_ruby_prepare() {
+ sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
+}
diff --git a/dev-ruby/timecop/timecop-0.7.4.ebuild b/dev-ruby/timecop/timecop-0.7.4.ebuild
new file mode 100644
index 000000000000..ca706cdd7d1f
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="https://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
+}
+each_ruby_prepare() {
+ sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
+}
diff --git a/dev-ruby/timecop/timecop-0.8.0.ebuild b/dev-ruby/timecop/timecop-0.8.0.ebuild
new file mode 100644
index 000000000000..1c43f76aa9c8
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="https://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Missing testdep activesupport
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
+ # FIXME after activesupport gained ruby22 support
+ rm test/time_stack_item_test.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
+}