summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/tokyocabinet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/tokyocabinet')
-rw-r--r--dev-ruby/tokyocabinet/Manifest1
-rw-r--r--dev-ruby/tokyocabinet/metadata.xml5
-rw-r--r--dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild36
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/tokyocabinet/Manifest b/dev-ruby/tokyocabinet/Manifest
new file mode 100644
index 000000000000..8179102a702a
--- /dev/null
+++ b/dev-ruby/tokyocabinet/Manifest
@@ -0,0 +1 @@
+DIST tokyocabinet-1.29.1.gem 18944 SHA256 e1df73a0101532a606abeda37bee483e3707e90ddb502631ec0b028f58fb1fb7 SHA512 c6614644996d2182f07c1f1e025184b42facadaf84dbbc4106ba754ff98ffaa8aa098406dda51ad86eeed7806c89e04c9fad62d2798c63c7203a734de3ab39f8 WHIRLPOOL 00ce07794dba172884f1762e6fcaabb253293bdc7b22dcc241ea83427ea39e08b95e2821138235250d2b9cd370001a921de6cccbeaffee69eaa9960070bdda97
diff --git a/dev-ruby/tokyocabinet/metadata.xml b/dev-ruby/tokyocabinet/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/tokyocabinet/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild b/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild
new file mode 100644
index 000000000000..55fa9ad62d4e
--- /dev/null
+++ b/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND+="dev-db/tokyocabinet"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake install DESTDIR="${D}"
+
+ each_fakegem_install
+}