summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-20 07:02:11 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-20 11:04:34 +0100
commited1d85748f0c48a861e516010e580397b1316974 (patch)
tree556b8b3a9ac667d9eb4fa92b431f251b2feaac0b /dev-ruby/treetop
parentdev-ruby/rash_alt: add ruby30 (diff)
downloadgentoo-ed1d85748f0c48a861e516010e580397b1316974.tar.gz
gentoo-ed1d85748f0c48a861e516010e580397b1316974.tar.bz2
gentoo-ed1d85748f0c48a861e516010e580397b1316974.zip
dev-ruby/treetop: add ruby30; EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/treetop')
-rw-r--r--dev-ruby/treetop/treetop-1.6.11-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/treetop/treetop-1.6.11-r1.ebuild b/dev-ruby/treetop/treetop-1.6.11-r1.ebuild
new file mode 100644
index 000000000000..4eb6fb5a2f01
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.6.11-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="treetop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="https://github.com/cjheath/treetop"
+SRC_URI="https://github.com/cjheath/treetop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1:0"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}