summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-12 07:14:37 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-12 07:14:37 +0200
commitd23475968a472e37165808f5b3502436eb691aba (patch)
tree2d6c0b28253c886618f4d9e2c2260f6a0912399d /dev-ruby/tty-which
parentdev-ruby/loofah: cleanup (diff)
downloadgentoo-d23475968a472e37165808f5b3502436eb691aba.tar.gz
gentoo-d23475968a472e37165808f5b3502436eb691aba.tar.bz2
gentoo-d23475968a472e37165808f5b3502436eb691aba.zip
dev-ruby/tty-which: add 0.5.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-which')
-rw-r--r--dev-ruby/tty-which/Manifest1
-rw-r--r--dev-ruby/tty-which/tty-which-0.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/Manifest b/dev-ruby/tty-which/Manifest
index 5f2616cd8c36..3196deab2a8a 100644
--- a/dev-ruby/tty-which/Manifest
+++ b/dev-ruby/tty-which/Manifest
@@ -1 +1,2 @@
DIST tty-which-0.4.2.tar.gz 9820 BLAKE2B 07ac2aa7a3e42127f456045fbdb92db2ea9834b08e0fccbe81767e01817ec2bf7304fb8a41408b0c4da8ecba3caf8bc236de9cb5637c6f197fe3835d0e9b231e SHA512 573b4ed1bfd4dd66dc3337d076a6559bda57b76c95c75f1aeef8bb6d4e0c81ef72057f5ef0521a10afb2a550b8850e6311aaa56ef2499146221f33403621ee54
+DIST tty-which-0.5.0.tar.gz 11560 BLAKE2B 0b8d821168759ff744ded5a5d7b0864303ed71510dd233b39b6f12fe42f044c4fb48da8f9b0cb16875ae9cce5c66060af8cff858aaa88bdaddfc971886f2ce8b SHA512 a5be30dc857eed2aa8ce81f1c62467451760482b1f51f1c0654c57001a9ab828d31b22b35cd9e37ea2fe91a7514a1a15107b5fc948a561a2ee4e58e0748bacd3
diff --git a/dev-ruby/tty-which/tty-which-0.5.0.ebuild b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
new file mode 100644
index 000000000000..2bd6b2425e01
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-which.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+SRC_URI="https://github.com/piotrmurach/tty-which/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix running specs without bundler, fixed upstream
+ sed -e 's/receive(:join)$/receive(:join).and_call_original/' \
+ -e '96iallow(::File).to receive(:join).and_call_original' \
+ -e '115iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/which_spec.rb || die
+ sed -e '5iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/executable_file_spec.rb || die
+}