summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-13 06:33:59 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-13 06:33:59 +0100
commit97813c9f247f5b92cfb40d28950d8e75c78e8b3a (patch)
treed73940450453bb58820a49bfd6409e9314c76aa4 /dev-ruby/typhoeus/typhoeus-1.3.1.ebuild
parentdev-ruby/method_source: add 0.9.2 (diff)
downloadgentoo-97813c9f247f5b92cfb40d28950d8e75c78e8b3a.tar.gz
gentoo-97813c9f247f5b92cfb40d28950d8e75c78e8b3a.tar.bz2
gentoo-97813c9f247f5b92cfb40d28950d8e75c78e8b3a.zip
dev-ruby/typhoeus: add 1.3.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/typhoeus/typhoeus-1.3.1.ebuild')
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild b/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild
new file mode 100644
index 000000000000..93bf4dcea13b
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="https://rubygems.org/gems/typhoeus/
+ https://github.com/typhoeus/typhoeus"
+
+LICENSE="Ruby"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}