summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-28 08:29:17 +0200
committerHans de Graaff <graaff@gentoo.org>2016-03-28 12:21:15 +0200
commit5304283d8c45cf132a1a04af66a4e3b527e86c3d (patch)
tree883d97f0a13c94e745dc124e539454147c293686 /dev-ruby/tzinfo/tzinfo-0.3.48.ebuild
parentdev-ruby/tzinfo: amd64 stable wrt bug #578432 (diff)
downloadgentoo-5304283d8c45cf132a1a04af66a4e3b527e86c3d.tar.gz
gentoo-5304283d8c45cf132a1a04af66a4e3b527e86c3d.tar.bz2
gentoo-5304283d8c45cf132a1a04af66a4e3b527e86c3d.zip
dev-ruby/tzinfo: add 0.3.48
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-0.3.48.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.48.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.48.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.48.ebuild
new file mode 100644
index 000000000000..e0fe5b3f4e71
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.48.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}