summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 12:38:39 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-24 07:37:11 +0100
commit5d7a4077ec80fdba320d7a8fd09fd6d708e93e2f (patch)
tree7c3ee4167b4499abe7660a74e2b095c682c47dab /dev-ruby/uconv
parentdev-ruby/totoridipjp: add ruby30 (diff)
downloadgentoo-5d7a4077ec80fdba320d7a8fd09fd6d708e93e2f.tar.gz
gentoo-5d7a4077ec80fdba320d7a8fd09fd6d708e93e2f.tar.bz2
gentoo-5d7a4077ec80fdba320d7a8fd09fd6d708e93e2f.zip
dev-ruby/uconv: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/uconv')
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/uconv/uconv-0.6.1-r3.ebuild b/dev-ruby/uconv/uconv-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..8af5f475d2da
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}