summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/unindent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/unindent')
-rw-r--r--dev-ruby/unindent/Manifest1
-rw-r--r--dev-ruby/unindent/metadata.xml8
-rw-r--r--dev-ruby/unindent/unindent-1.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/unindent/Manifest b/dev-ruby/unindent/Manifest
new file mode 100644
index 000000000000..49eec823ba89
--- /dev/null
+++ b/dev-ruby/unindent/Manifest
@@ -0,0 +1 @@
+DIST unindent-1.0.gem 6144 SHA256 2db32ae30df3331d7c07c92121b115b25e3c7ab7b1beb8e2f70915b47f1e10f3 SHA512 1bab3352fc8da8b8a3ade8dff2f7c565e36529a79ca68c0a1ca73cdeca93fa507baa9399c6eed4fa020aa74dea6c4260a0242fa8057931a90bc172f138a5e655 WHIRLPOOL bdef1ecdb2dd386bcae247af4bb49d34c6088883701eeef4dfb7930077ca13989dbe4fb925abe7b4b656aed212f12bd3b661afdfded32ef56a93eabd45c75195
diff --git a/dev-ruby/unindent/metadata.xml b/dev-ruby/unindent/metadata.xml
new file mode 100644
index 000000000000..5502a21c145c
--- /dev/null
+++ b/dev-ruby/unindent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mynyml/unindent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/unindent/unindent-1.0.ebuild b/dev-ruby/unindent/unindent-1.0.ebuild
new file mode 100644
index 000000000000..4be74c7d437b
--- /dev/null
+++ b/dev-ruby/unindent/unindent-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby method to unindent strings"
+HOMEPAGE="https://github.com/mynyml/unindent"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/nanotest )"
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_unindent.rb || die
+}