summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-25 08:17:32 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-25 08:17:32 +0200
commit92a2d04a210d5b37b4715e6bb198025c29614f50 (patch)
tree69065b1487ca98153780b56d1109a5643c799f51 /dev-ruby/vcard/vcard-0.2.13.ebuild
parentdev-lang/julia: Respect $(get_libdir) and install libjulia.so at right place (diff)
downloadgentoo-92a2d04a210d5b37b4715e6bb198025c29614f50.tar.gz
gentoo-92a2d04a210d5b37b4715e6bb198025c29614f50.tar.bz2
gentoo-92a2d04a210d5b37b4715e6bb198025c29614f50.zip
dev-ruby/vcard: add 0.2.13
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/vcard/vcard-0.2.13.ebuild')
-rw-r--r--dev-ruby/vcard/vcard-0.2.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/vcard/vcard-0.2.13.ebuild b/dev-ruby/vcard/vcard-0.2.13.ebuild
new file mode 100644
index 000000000000..a645797244fc
--- /dev/null
+++ b/dev-ruby/vcard/vcard-0.2.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=none
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby vcard support extracted from Vpim"
+HOMEPAGE="https://github.com/qoobaa/vcard"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --load-path=lib --pattern='.*_test\.rb' test/
+}