summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-13 07:38:15 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-13 07:38:15 +0100
commit24849d007acc23861d55260f291cc599b907cfc0 (patch)
tree71354f7bdbd005c0733f782e5124fbb95356001c /dev-ruby/webrobots/webrobots-0.1.2.ebuild
parentapp-emulation/wine: Exclude staging patch that breaks -nls, Bug #577198 (diff)
downloadgentoo-24849d007acc23861d55260f291cc599b907cfc0.tar.gz
gentoo-24849d007acc23861d55260f291cc599b907cfc0.tar.bz2
gentoo-24849d007acc23861d55260f291cc599b907cfc0.zip
dev-ruby/webrobots: add 0.1.2
Drop ppc, x86 keywords due to missing webmock keywords, bug 563858 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/webrobots/webrobots-0.1.2.ebuild')
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/webrobots-0.1.2.ebuild b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
new file mode 100644
index 000000000000..eaf85376364a
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}