summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-10-16 06:09:24 +0200
committerHans de Graaff <graaff@gentoo.org>2018-10-16 06:09:24 +0200
commit2eb72ed69752d19e9448787367647ea23d88ca31 (patch)
treeaff5a404f151bdd4a1efd3540d5468b4b8643ef1 /dev-ruby/xpath/xpath-3.2.0.ebuild
parentdev-python/sphinx: remove old (diff)
downloadgentoo-2eb72ed69752d19e9448787367647ea23d88ca31.tar.gz
gentoo-2eb72ed69752d19e9448787367647ea23d88ca31.tar.bz2
gentoo-2eb72ed69752d19e9448787367647ea23d88ca31.zip
dev-ruby/xpath: add 3.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/xpath/xpath-3.2.0.ebuild')
-rw-r--r--dev-ruby/xpath/xpath-3.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/xpath/xpath-3.2.0.ebuild b/dev-ruby/xpath/xpath-3.2.0.ebuild
new file mode 100644
index 000000000000..e5e5655d1228
--- /dev/null
+++ b/dev-ruby/xpath/xpath-3.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+SLOT="3"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.8:0"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}