summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-20 07:33:13 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-20 07:33:13 +0200
commite1fb925d0d5747a7c0e9516c67d6e43c6cb78b51 (patch)
treea7ae2c1bcae3b9010520cc14246b96bed51ebcae /dev-ruby/yajl-ruby
parentdev-ruby/rspec-core: fix dep issue with USE=doc (diff)
downloadgentoo-e1fb925d0d5747a7c0e9516c67d6e43c6cb78b51.tar.gz
gentoo-e1fb925d0d5747a7c0e9516c67d6e43c6cb78b51.tar.bz2
gentoo-e1fb925d0d5747a7c0e9516c67d6e43c6cb78b51.zip
dev-ruby/yajl-ruby: use correct version of rspec
Specify the correct version of rspec to be used. Since we need to use a manual invocation to set RUBYLIB we must also specific the version, since the default is to use rspec 2.x. Closes: https://bugs.gentoo.org/635312 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/yajl-ruby')
-rw-r--r--dev-ruby/yajl-ruby/yajl-ruby-1.3.1.ebuild2
-rw-r--r--dev-ruby/yajl-ruby/yajl-ruby-1.4.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/yajl-ruby/yajl-ruby-1.3.1.ebuild b/dev-ruby/yajl-ruby/yajl-ruby-1.3.1.ebuild
index 3211a411b19f..778feca9ad5b 100644
--- a/dev-ruby/yajl-ruby/yajl-ruby-1.3.1.ebuild
+++ b/dev-ruby/yajl-ruby/yajl-ruby-1.3.1.ebuild
@@ -41,5 +41,5 @@ each_ruby_compile() {
each_ruby_test() {
# Set RUBYLIB to pass search path on to additional interpreters that
# are started.
- RUBYLIB=lib ruby-ng_rspec || die
+ RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec || die
}
diff --git a/dev-ruby/yajl-ruby/yajl-ruby-1.4.0.ebuild b/dev-ruby/yajl-ruby/yajl-ruby-1.4.0.ebuild
index 8c309083d19f..d9cb6a9d9beb 100644
--- a/dev-ruby/yajl-ruby/yajl-ruby-1.4.0.ebuild
+++ b/dev-ruby/yajl-ruby/yajl-ruby-1.4.0.ebuild
@@ -41,5 +41,5 @@ each_ruby_compile() {
each_ruby_test() {
# Set RUBYLIB to pass search path on to additional interpreters that
# are started.
- RUBYLIB=lib ruby-ng_rspec || die
+ RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec || die
}