summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-14 07:09:36 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-14 07:32:16 +0200
commit055a3ed0da95eb577b0b01bc988c9d4affe5c9b8 (patch)
treed8ab537f63b69bc2c8066916cd8ec0938965f820 /dev-ruby
parentsys-apps/openrc: 0.44.6-r1 bump (diff)
downloadgentoo-055a3ed0da95eb577b0b01bc988c9d4affe5c9b8.tar.gz
gentoo-055a3ed0da95eb577b0b01bc988c9d4affe5c9b8.tar.bz2
gentoo-055a3ed0da95eb577b0b01bc988c9d4affe5c9b8.zip
dev-ruby/selenium-webdriver: add 4.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index c5ae7412c95d..dfd0962f0e19 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -1 +1,2 @@
DIST selenium-webdriver-3.142.7.gem 865280 BLAKE2B 650011848afaa3ea4fab7c8172828c7562df212383a8fbea9615a5136e3382aba0fcf17952d941c7b514e5229c0aafe3dbc320386698eb8756f567eff67722bd SHA512 0e7891c19b8a0b20441d85bc17032ecf03cba7ca435846e03abc50b62b0c53c075dc70456796c9bfcd1ecd28ecc517f907a3d6868346a07617fd1d0c1b9437c0
+DIST selenium-webdriver-4.0.0.gem 152576 BLAKE2B 8a1394fb1c9cc3603081454c4946f0ad5207d113bb37c488207baaaaaff69f2848b2b5bc9b9221177d01c86b635dd222933be3561eacfa164539c99c8cf149a6 SHA512 db8fd0a05fc38e7f55c2b9a779462416b937d3b8e732dee6b7bcf2b3f8914417a79e8649e320e348359ab133cef20a75e2033385e8b125e5dfc52645b086045b
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild
new file mode 100644
index 000000000000..48a9afa6621d
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_GEMSPEC="selenium-webdriver.gemspec"
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubyzip-1.2.2:*"