summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-10 10:56:37 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-10 10:57:19 +0100
commit0690a68a83f1f8f6c9d83e83d91252b3f7c9dd38 (patch)
treec4f7e3307b9638ee34bfd1687e4c5e381ec25ac1 /dev-ruby
parentdev-ruby/nenv: add ruby26 (diff)
downloadgentoo-0690a68a83f1f8f6c9d83e83d91252b3f7c9dd38.tar.gz
gentoo-0690a68a83f1f8f6c9d83e83d91252b3f7c9dd38.tar.bz2
gentoo-0690a68a83f1f8f6c9d83e83d91252b3f7c9dd38.zip
dev-ruby/celluloid: add 0.17.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/celluloid/Manifest1
-rw-r--r--dev-ruby/celluloid/celluloid-0.17.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/celluloid/Manifest b/dev-ruby/celluloid/Manifest
index 76df61c527a2..6db06b216a2f 100644
--- a/dev-ruby/celluloid/Manifest
+++ b/dev-ruby/celluloid/Manifest
@@ -1 +1,2 @@
DIST celluloid-0.17.3.gem 61952 BLAKE2B 5b64b67dea84261706acaf2612c23cb0b82d6af7fe0eece9d9e17e5d948d83a81b0de7598a1709fb5e1073f3632c7df6d6730c4797e0a4da593795b85c3bf9e1 SHA512 bb5005452ef7a2da1fb6b6515a6ad9df992dfd043caa605d1282a24b874c1f0798da0d19ee00f434486f9ef2c9467b1d6d2cadaa7883db98b885eeb842f1b94c
+DIST celluloid-0.17.4.gem 61952 BLAKE2B e6432f76aa2548f9b734502954cae7aaaa2cc6658ae644591fe22bd25e53e4eb88ef81f41416162c7478a77622f400040695861f9557578c029c3860cdb800b5 SHA512 ab876a12db908d0b14b9a701bbf7c2530188559cb60b1832e76642fae843f4eca9f4790a60ff88dda8ff92f7051f2df222c19cdec77666fc2e8d6d15adbba793
diff --git a/dev-ruby/celluloid/celluloid-0.17.4.ebuild b/dev-ruby/celluloid/celluloid-0.17.4.ebuild
new file mode 100644
index 000000000000..0d7dae6155c5
--- /dev/null
+++ b/dev-ruby/celluloid/celluloid-0.17.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ruby25: fails tests
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+# Needed by packages writing specs for celluloid
+RUBY_FAKEGEM_EXTRAINSTALL="spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend "
+ dev-ruby/celluloid-essentials
+ dev-ruby/celluloid-extras
+ dev-ruby/celluloid-fsm
+ dev-ruby/celluloid-pool
+ dev-ruby/celluloid-supervision
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '1irequire "spec_helper"' spec/celluloid/actor/system_spec.rb || die
+
+ sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die
+ mkdir log || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24)
+ sed -i -e '/String expected, but Fixnum received/ s/Fixnum/Integer/' spec/shared/actor_examples.rb || die
+ ;;
+ esac
+}