summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-16 06:40:56 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-16 06:42:05 +0100
commit08aecff1265f8b048a9505eb662ce435788ef1ed (patch)
tree7fc6bb1695a944e21764ed6f38eab2025bf27e80 /dev-ruby
parentdev-ruby/actionview: add 6.1.4.4 (diff)
downloadgentoo-08aecff1265f8b048a9505eb662ce435788ef1ed.tar.gz
gentoo-08aecff1265f8b048a9505eb662ce435788ef1ed.tar.bz2
gentoo-08aecff1265f8b048a9505eb662ce435788ef1ed.zip
dev-ruby/actionpack: add 6.1.4.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-6.1.4.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index ec7db6bdf37e..da694f6ceab9 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -4,3 +4,4 @@ DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbd
DIST rails-6.0.4.4.tgz 18594292 BLAKE2B 8f463900db30ffd4850b270aac0ae8c160af36a606e4eddaadbd2a0c086de3438a36665586e20a4b6b8873f8b659f2ecd3e32965a36118a6e63fad2726afa0f5 SHA512 14f7d51ba407589eb4ef1db8a99c21c301198e8cb2fcdf611c76eebd1d52192eb1225bb5d45a2183fbfe103a0b987f3a95c6c5fe6d772ba101da9ed46441441f
DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
DIST rails-6.1.4.3.tgz 11007190 BLAKE2B 085d500407f03d8c46335d91e3ebc5cd092c801de25f7e4fd5ac4ae6f03e54c5347e720386763307e183e2f0f48aaf84142092f47b62ab395082e4068e46f883 SHA512 f47a2e155fc80c287360b1a17a0f870208c523a28b77737648b4f260dc4fec6e9ccc91861b84862828fda48c214d39dcff32430ed5a02c8b9ee59ba6efb6151c
+DIST rails-6.1.4.4.tgz 11006695 BLAKE2B af5afbd1adafa259f3d58d31e8e616be5e83e73d3e7231fd62717c0a8c0012e7ecf5346f2465a61f72d96fdc71755e954069adfebc84dddddcb29cb8a215cee1 SHA512 4215be8f447e5b486a1c0d99208fbeb1f7222aa3bdff7127e31c95670a74aa315a044df0048a55fd078f42a07f17d4b7248efc09d6fac2a4b6efef8624a509ef
diff --git a/dev-ruby/actionpack/actionpack-6.1.4.4.ebuild b/dev-ruby/actionpack/actionpack-6.1.4.4.ebuild
new file mode 100644
index 000000000000..e5771567378e
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-6.1.4.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.2
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.2.0:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-2.15
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ www-servers/puma
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Use different timezone notation, this changed at some point due to an external dependency changing.
+ sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
+
+ # Avoid tests depending on an unreleased version of selenium-webdriver
+ sed -i -e '/define extra capabilities/,/^ end/ s:^:#:' test/dispatch/system_testing/driver_test.rb || die
+}