summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-09 07:48:57 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-09 07:49:29 +0200
commit0efc6ad6c6deba1f262e2d79bcabcf77a94c56e0 (patch)
tree63a850d91eaf90a6f2fbc6f4ced70faf1e27ec80 /dev-ruby
parentdev-ruby/naught: version bump (diff)
downloadgentoo-0efc6ad6c6deba1f262e2d79bcabcf77a94c56e0.tar.gz
gentoo-0efc6ad6c6deba1f262e2d79bcabcf77a94c56e0.tar.bz2
gentoo-0efc6ad6c6deba1f262e2d79bcabcf77a94c56e0.zip
dev-ruby/pg_array_parser: fix many issues.
Fix LICENSE. Fix USE=doc and FEATURES=test. Actually compile and install the compiled extension. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r1.ebuild (renamed from dev-ruby/pg_array_parser/pg_array_parser-0.0.9.ebuild)22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-ruby/pg_array_parser/pg_array_parser-0.0.9.ebuild b/dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r1.ebuild
index c1f969168ae5..e70da9808075 100644
--- a/dev-ruby/pg_array_parser/pg_array_parser-0.0.9.ebuild
+++ b/dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r1.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Id$
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
inherit ruby-fakegem versionator
DESCRIPTION="Simple library to parse PostgreSQL arrays into a array of strings"
HOMEPAGE="https://github.com/dockyard/pg_array_parser"
-SRC_URI="mirror://rubygems/${P}.gem"
-LICENSE="BSD"
+LICENSE="MIT"
SLOT="$(get_version_component_range 1-3)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
-RESTRICT=test
ruby_add_bdepend "dev-ruby/bundler"
@@ -40,3 +43,12 @@ each_ruby_prepare() {
BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
fi
}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/pg_array_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/pg_array_parser V=1
+ cp ext/pg_array_parser/pg_array_parser.so lib/
+}