summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-11 10:27:48 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-11 10:31:31 +0100
commit129a4e3796095e0030dd59013b88810e73563f2f (patch)
treea6d27742a1c29d81b964721ad931a2cfba664310 /dev-ruby
parentdev-ruby/strptime: add ruby30; fix extension (diff)
downloadgentoo-129a4e3796095e0030dd59013b88810e73563f2f.tar.gz
gentoo-129a4e3796095e0030dd59013b88810e73563f2f.tar.bz2
gentoo-129a4e3796095e0030dd59013b88810e73563f2f.zip
dev-ruby/mustache: fix tests
Closes: https://bugs.gentoo.org/775371 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mustache/files/mustache-1.1.1-test-ordering.patch36
-rw-r--r--dev-ruby/mustache/mustache-1.1.1.ebuild6
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ruby/mustache/files/mustache-1.1.1-test-ordering.patch b/dev-ruby/mustache/files/mustache-1.1.1-test-ordering.patch
new file mode 100644
index 000000000000..824825bacbd3
--- /dev/null
+++ b/dev-ruby/mustache/files/mustache-1.1.1-test-ordering.patch
@@ -0,0 +1,36 @@
+From 407c6a5db6c1f1cfb40bd6113f07f067d07885a4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
+Date: Mon, 27 Apr 2020 11:16:17 +0200
+Subject: [PATCH] Fix test race condition.
+
+The test suite randomly fails with errors such as:
+
+~~~
+ 1) Failure:
+AutoloadingTest#test_autoload_lowercase [/builddir/build/BUILD/mustache-1.1.1/usr/share/gems/gems/mustache-1.1.1/test/autoloading_test.rb:17]:
+Expected: Comments
+ Actual: nil
+~~~
+
+This happens when `test_namespaced*` test cases are executed earlier
+than the remaining test cases, because they are defining
+`view_namespace` but not cleaning up afterwards.
+---
+ test/autoloading_test.rb | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/test/autoloading_test.rb b/test/autoloading_test.rb
+index 0a7ad762..77eb3557 100644
+--- a/test/autoloading_test.rb
++++ b/test/autoloading_test.rb
+@@ -7,6 +7,10 @@ def setup
+ Mustache.view_path = File.dirname(__FILE__) + '/fixtures'
+ end
+
++ def teardown
++ Mustache.remove_instance_variable(:@view_namespace) if Mustache.instance_variable_defined?(:@view_namespace)
++ end
++
+ def test_autoload
+ klass = Mustache.view_class(:Comments)
+ assert_equal Comments, klass
diff --git a/dev-ruby/mustache/mustache-1.1.1.ebuild b/dev-ruby/mustache/mustache-1.1.1.ebuild
index 12424c6fe07f..76e8a8f9ed87 100644
--- a/dev-ruby/mustache/mustache-1.1.1.ebuild
+++ b/dev-ruby/mustache/mustache-1.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26"
RUBY_FAKEGEM_TASK_TEST=""
@@ -20,6 +20,8 @@ SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
IUSE=""
+PATCHES=( "${FILESDIR}/${P}-test-ordering.patch" )
+
ruby_add_bdepend "doc? ( app-text/ronn )"
all_ruby_prepare() {