summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-13 15:23:01 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-13 15:23:01 +0100
commit306f70a0f64401bdb45188d982d07253df1f01ae (patch)
tree45daa03bead5324be487c199287dc24323112ffc /dev-ruby
parentdev-ruby/duktape-rb: new package (diff)
downloadgentoo-306f70a0f64401bdb45188d982d07253df1f01ae.tar.gz
gentoo-306f70a0f64401bdb45188d982d07253df1f01ae.tar.bz2
gentoo-306f70a0f64401bdb45188d982d07253df1f01ae.zip
dev-ruby/duktape-rb: add a version supporting running tests
Will still keep the test-restricted one around in case it turns out keywording and stabilising dev-ruby/sdoc and its dependencies on ppc turns out to be too complex, as we need a ppc-stable version of duktape-rb rather soon. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r1.ebuild b/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r1.ebuild
new file mode 100644
index 000000000000..24d4c00ed157
--- /dev/null
+++ b/dev-ruby/duktape-rb/duktape-rb-2.3.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_GEMSPEC="duktape.gemspec"
+RUBY_FAKEGEM_NAME="duktape"
+
+inherit ruby-fakegem
+
+MY_PN=${PN/-/\.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Ruby bindings to the Duktape JavaScript interpeter"
+HOMEPAGE="https://github.com/judofyr/duktape.rb"
+SRC_URI="https://github.com/judofyr/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND+="dev-lang/duktape"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ dev-ruby/sdoc
+ )"
+
+RUBY_S=${MY_P}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile
+}