summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-25 07:03:16 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-25 07:03:16 +0200
commit348c2f1662f7467d34000e27a33f0568e27c72b7 (patch)
treebae934b4b8e8e2e7b67e0dcd792bfb4aa432b870 /dev-ruby
parentmedia-tv/xmltv: Dropped to ~ppc, bug 652902 (diff)
downloadgentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.tar.gz
gentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.tar.bz2
gentoo-348c2f1662f7467d34000e27a33f0568e27c72b7.zip
dev-ruby/connection_pool: add 2.2.2
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/connection_pool/Manifest1
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index fabc9bec68f3..35483dfbcd71 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1 +1,2 @@
DIST connection_pool-2.2.1.gem 13824 BLAKE2B 2328a86f9d625d245f3e74d41fd615d95ea68a6fb8b1d17a9a0f9dc4ff8b772eb2942fd9103b12875a4ea2f3b6d922227a4da79fc61bd348d4bae5aa50b442a2 SHA512 74167b200fcc02d3a60fdc0e71b44c80f1c72db75b5f604a442bd5fb55138fe1750a2db095e0283104fda35fd9024cb71c7ddb614c3d472f814d686b686b6ef0
+DIST connection_pool-2.2.2.gem 13824 BLAKE2B 2f52bb3451dec5916d5797596f7bc3dbf39845321ee83736d679c433e96f154db852469b1f6d0d3b7c7f48262f7840087d89cdd40ece22b67a29c20ff77274dd SHA512 74cb64aa3f183ee4e41f438133f60581e9f99a1d5b5daf61607cff2329bfb1fbd8810d87c35d709418a22ad925049e3e9403a602107452414a67aee1c6eecfe9
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
new file mode 100644
index 000000000000..97a8f019f2a1
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}