summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-15 07:08:07 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-15 07:08:07 +0200
commit582ac2400fc89d9d62557a795702f158fb761ffa (patch)
treedd15d50e7fbe41e552fef0381f640d66c38f78c0 /dev-ruby
parentnet-analyzer/netdata: 1.25.0 version bump (diff)
downloadgentoo-582ac2400fc89d9d62557a795702f158fb761ffa.tar.gz
gentoo-582ac2400fc89d9d62557a795702f158fb761ffa.tar.bz2
gentoo-582ac2400fc89d9d62557a795702f158fb761ffa.zip
dev-ruby/pkg-config: add 1.4.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pkg-config/Manifest1
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index 043102892305..367d77bde433 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,2 +1,3 @@
DIST pkg-config-1.4.1.gem 22016 BLAKE2B efac610221b288bb669a3783c0e70af3951478147896315c53af2186912b60045096c0ba01a0a59ce09897a2e4e747d28a091b947281fe7f6dd6f85cea31aae7 SHA512 72d61466c1ea53a5eda66a8e8f8106fef0269fefdd349ac83959a34bb8f36796bd3e9c7fbcbad5763d2fca015c65436f9d410724e27b6d1c495e3957d26757a6
DIST pkg-config-1.4.2.gem 22016 BLAKE2B fb8f32c811f856d11653fc0450e5615d83dea07f07f712b4914edfdca1e35f9b2da7d04578c9f28a1562cb0a405e54f6429cfac792ca2f86710d18c30a75be71 SHA512 f727f416860b08e87390c60800333bab7b0d6238fe1f93bc12b92ec67ca75c5c9ad128332a54a0b895dbf49944a50619e3bf40c49efcc7e73811d51714ae3d66
+DIST pkg-config-1.4.3.gem 22016 BLAKE2B a23bfee3790a03d4224efe16439b1c43a6174336b567d7c84d429e848035f7c77d96340e677a7f75e3cef415f236cc1d09cc0f75bee5d8769e9490bc2fc5f4c8 SHA512 4952636442d585b555d048666937e568f237789329ed6110475efe149d607f4b1946ce1b616574a91de7e4c17ef9cc5cc3b4bb2867a7dc08344183a41303f42d
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.3.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.3.ebuild
new file mode 100644
index 000000000000..2ebdd50bb933
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}